Autor Thema: neues, altes Bernard Starterpack für 2.72  (Gelesen 14788 mal)

KhrisMUC

  • Mod
  • volljähriger Tentakel
  • **
  • Beiträge: 988
    • Profil anzeigen
Re: neues, altes Bernard Starterpack für 2.72
« Antwort #45 am: 06. Juni 2007, 13:30:19 »
Die Fehlermeldung heißt wahrscheinlich "nested functions not supported".

Wenn Du eine Klammer vergessen hast, sieht das ohne Inhalt so aus:

function x {
  ...

// hier sollte eigentlich eine } hin


function y {
  ...
Für AGS ist der Fehler aber erst in der Zeile mit "function y", da man keine Funktion innerhalb einer anderen deklarieren kann. Deswegen schickt es den Cursor dorthin.

Das Zeug bei Hotspot 8 ist wohl ein Überbleibsel auf dem Wendy-Pack. Es ist allerdings ziemlich mühsam, das alles von Hand zu entfernen; und die paar überflüssigen Zeilen stören ja nicht wirklich.
Vorsicht: falls man das doch löschen will, einfach hotspot 8 auswählen (auch, wenn er gar nicht eingezeichnet ist, AGS ist das wurscht) und dort in den Interactions die RunScript-action löschen. Nie den Code einfach so entfernen.

Übrigens, wo ich das grad sehe:
Der Hotspot-Code ist nicht nur veraltet, sondern auch unnötig lang. Siehe hier:
http://www.adventure-treff.de/forum/viewtopic.php?t=7529&start=4

steve-o-mat

  • volljähriger Tentakel
  • *****
  • Beiträge: 617
  • Geschlecht: Männlich
    • ICQ Messenger - 481703404
    • Profil anzeigen
Re: neues, altes Bernard Starterpack für 2.72
« Antwort #46 am: 06. Juni 2007, 17:07:26 »
Hallo KhrisMUC!
Danke für die Hilfe und den Link!  :)

Nie den Code einfach so entfernen.

Ja diese bittere Erfahrung habe ich schon machen dürfen.  :)

Die Fehlermeldung heißt wahrscheinlich "nested functions not supported".

Nee, eigentlich nicht. Die, die ich hatte, habe ich in meinem letzten Beitrag gepostet.
("There was an error compiling your script. In: 'Room 19 script' ... you may have forgotten a closing brace")

Der Hotspot-Code ist nicht nur veraltet, sondern auch unnötig lang.

Die Standard-Hotspots in dem Starterpack sind alle so geschrieben, aber ich hab das bei einigen Sachen schon geändert. Ich halte mich Code-technisch an das Tutorial von Timer, also sieht das bei mir in etwa so aus:

if (any_click_move (x,y,dir))
if (UsedAction (A_OPEN))
{
ObjectOn (x);
PlaySound (x);
player.Say ("blablabla");
}
else if (UsedAction (A_PUSH))
{
...
}

steve-o-mat

  • volljähriger Tentakel
  • *****
  • Beiträge: 617
  • Geschlecht: Männlich
    • ICQ Messenger - 481703404
    • Profil anzeigen
Re: neues, altes Bernard Starterpack für 2.72
« Antwort #47 am: 14. August 2007, 17:51:48 »
Ich will ja jetzt nicht als Erbsenzähler dastehen  8), aber mir vor geraumer Zeit ist ein kleiner optischer Fehler im Starterpack aufgefallen. Seht selbst:



(für alle die es nicht erkennen, der Stuhl ist quasi mit dem Hintergrund (genauer der Scheuerleiste) verwachsen. Wer es immernoch nicht erkennt, vergleiche bitte mit dem anderen Stuhl.  ;)).

Wollt es bloß mal loswerden und vielleicht kann jemand im neuen Starterpack die 2 schwarzen Pixel dazumalen.  ;D  ;)

steve-o-mat

  • volljähriger Tentakel
  • *****
  • Beiträge: 617
  • Geschlecht: Männlich
    • ICQ Messenger - 481703404
    • Profil anzeigen
Re: neues, altes Bernard Starterpack für 2.72
« Antwort #48 am: 14. August 2007, 19:04:21 »
Weil ich schonmal dabei war...
Ich weiß nicht, obs nur mir so geht, aber mich hat schon immer das Geländer im ersten Stock gestört. Habs mal überarbeitet. Wenns gefällt, könnte man das ja auch noch im Starterpack umändern (würd ich auch selber machen.)

Hier die ursprüngliche Version:



Und hier die überarbeitete:


Cossack

  • kleiner Tentakelsaugknopf
  • **
  • Beiträge: 89
  • Geschlecht: Männlich
    • Profil anzeigen
Re: neues, altes Bernard Starterpack für 2.72
« Antwort #49 am: 25. August 2007, 18:23:41 »
Just to ask: Why in the 2.72 version of the Starterpack all fonts used are so small? That cause problems to see the game in 640x480 definition.
Das ist der Meteor!

Cone Arex

  • Mod
  • alter Tentakel
  • **
  • Beiträge: 2295
  • Geschlecht: Männlich
  • Skandal-Entwickler und Idiot
    • Profil anzeigen
    • Conequest
Re: neues, altes Bernard Starterpack für 2.72
« Antwort #50 am: 25. August 2007, 18:29:48 »
In the general settings is "Don't scale up fonts at 640x400" activatet. You must deactivat it.


Folge mir auf X und itch.io

JPS

  • Midlife Crisis Tentakel
  • ******
  • Beiträge: 1033
    • Profil anzeigen
Re: neues, altes Bernard Starterpack für 2.72
« Antwort #51 am: 25. August 2007, 19:16:17 »
Wirst du auch die verbesserten Raumgrafiken aus Futuranis 1&3 einbauen?

KhrisMUC

  • Mod
  • volljähriger Tentakel
  • **
  • Beiträge: 988
    • Profil anzeigen
Re: neues, altes Bernard Starterpack für 2.72
« Antwort #52 am: 25. August 2007, 21:37:18 »
Just to ask: Why in the 2.72 version of the Starterpack all fonts used are so small? That cause problems to see the game in 640x480 definition.
DON'T switch to the higher res but use the x2 or x3 graphics filter instead.
It's a vital difference whether you use native 640x400 or an upscaled 320x200.

The first method will make the game run at a true high res, so e.g. scaled characters use all the high res-"small" pixels. Plus, the game will increase the font size resulting in a high-res, rounded font.
Both effects kill the original pixelated look of MMM.

With the graphics filter, the engine renders the screen at 320x200, then scales it up to twice or thrice its size, thus keeping the original look of the game.