Autor Thema: Umlaute bei Savegames?  (Gelesen 1533 mal)

Helli78

  • Teenie Tentakel
  • ****
  • Beiträge: 367
    • Profil anzeigen
Umlaute bei Savegames?
« am: 20. November 2010, 22:17:12 »
Hey Leute,

mir ist gerade was aufgefallen. Ich weiß nicht, obs an mir, am System oder sonstigen Einstellungen liegt, aber:

Ich spiele TMMCMFH (höhö, was sonst?). Ich speichere ab und benutze dabei einen Umlaut (in meinem Fall das Ü). Beim anschließenden Laden sehe ich, dass dieses Wort ab (und inklusive) dem Ü abgeschnitten ist.
Die AGS-Version ist 3.12.1074.

Bug, gewollt, oder sprachliche Barriere mit dem Englischen ....?

Bòógieman

  • International anerkannter Superheld
  • Globaler Moderator
  • alter Tentakel
  • *****
  • Beiträge: 2657
  • Geschlecht: Männlich
  • Grün Tentakel = Running Sushi!
    • Profil anzeigen
Re: Umlaute bei Savegames?
« Antwort #1 am: 21. November 2010, 12:53:59 »
ich hab da nix dran verändert, also der fehler muss wohl schon so im tollhaus-starterpack gewesen sein (und wahrscheinlich in allen anderen starterpacks)
was hast du denn für ein betriebssystem?
Schlachtaman Vibrations, UHYEAH!!!
_________________________________

>>>> Ende der Kommunikation <<<<

KhrisMUC

  • Moderator
  • volljähriger Tentakel
  • *****
  • Beiträge: 988
    • Profil anzeigen
Re: Umlaute bei Savegames?
« Antwort #2 am: 21. November 2010, 13:22:42 »
Der String wird im savegame abgelegt und der entsprechende Engine-Code ist wahrscheinlich uralt, wurde also nie "sonderzeichenfähig" gemacht.
Ich schätze mal, dass das generell bei AGS so läuft, nicht nur bei den Starterpacks.
Wenn ich in einem Defaultgame beim Speichern Umlaute eintippen will, passiert nix. Die Starterpacks verwenden zum Benennen ein Textfeld dessen Inhalt dann weitergegeben wird. Textfelder erlauben das Eingeben von Umlauten, aber beim Speichern selbst wird wohl einfach beim ersten Sonderzeichen abgeschnitten.